Back to overview
Resolved

Dashboard Performance & Security Upgrade

Jul 28, 2026 at 5:12am UTC  –  Jul 28, 2026 at 5:22am UTC
Affected services
Client Portal

Resolved
Jul 28, 2026 at 5:22am UTC

The scheduled maintenance is complete and n8n LaunchPad is back to full operation. ✅

What's live now:

  1. Faster dashboard load times across the board
  2. Per-user session security is now active — you may be asked to log in again on your next visit
  3. Payment gateway is optimized for quicker, smoother checkouts

Everything's running smoothly. If you notice any issues, reach out to us and we'll jump on it right away.

Thanks for your patience while we shipped this. 🚀

Created
Jul 28, 2026 at 5:12am UTC

We're rolling out improvements to the n8n LaunchPad dashboard to make your experience faster and more secure.

What's changing:
1. Faster dashboard load times and overall performance
2. Enhanced security with per-user session management
3. Optimized payment gateway for quicker, smoother checkouts

What to expect:
You may experience brief interruptions or need to log in again during this window. No workflows or automations will be affected — this update is limited to the dashboard and billing layer.